Sunday, February 27, 2005

My worst fear...

Oviously!
Its setting up a mail server!

From past 2 days, i'm banging my head against docs for qmail to get it running on gentoo. Qmail's docs are good, infact wonderfull, but being on a non-legacy system, i need to be extra-extra carefull. I cannot afford to make mistakes as every mistake can set me back by atleast 2 hours of re-compilation. Hence, golden words for me are : "Learn from other's mistakes" :-D

Anyways, i WILL set up Qmail this week & give my family members their own address, like :
--------
piddi@makuchaku.whatever.i.can.get.free.com
--------
however big it may look!

Signing off,

11 comments:

माकूचाकू said...

Its actually not any fear...
but since i have never touched this "mail-admin" part, i'm a bit scared of it.

anyways...

cya
QuakuChaku
:-)

माकूचाकू said...

Update
------

Qmail will be delivering things at
[user]@makuchaku.homelinux.org

:-)

माकूचाकू said...

Update
------

Oh!
Btw, my address will be
me@makuchaku.homelinux.org

माकूचाकू said...

Update
------

As i said, any mistake will put me back by atleast 2 hrs...

...forgot to set/enable "maildir imap" in USE flags! [docs]Shit!!!

Compiling everything (qmail'n stuff) again!!!

Lesson learnt!
DO NOT BLINDLY INSTALL ANYTHING BEFORE rtfm

:-(
cya after 2 hrs...
me@makuchaku.homelinux.org

माकूचाकू said...

Update
------

Well, it wasnt so bad afterall!
After 15 minutes of recompilation/re-configuration, atleast my "maildirs" are working & i'm getting local mails via qmail-inject :-)

cheers!

माकूचाकू said...

Update
------

"If it can go wrong, it will go wrong!!!"

emerging mysql again to correct vpopmail error. Mysql is compiling from past 1 hour :((

me@makuchaku@homelinux.org

माकूचाकू said...

Update
------

SMTP is running perfect, though w/o any auth. pop3/imap is giving some auth errors, which i'll solve sooner (rather than later)!

:-)
piddi@makuchaku.homelinux.org

Anonymous said...

Ankit Says

Maku, here is a suggestion. Can you make a HOWTO for it for the 'non-legacy' system you are on ? Puhleeze. So that someone else will be saved of the headache ;-)

Waiting for it..

Oh BTW congrats :)

_________________________

Ankit Malik
http://scribbler.tk

Anonymous said...

Ankit Says

Maku, here is a suggestion. Can you make a HOWTO for it for the 'non-legacy' system you are on ? Puhleeze. So that someone else will be saved of the headache ;-)

Waiting for it..

Oh BTW congrats :)

_________________________

Ankit Malik
http://scribbler.tk

माकूचाकू said...

Hey ankit :-)

An ultra Qewl, to-the-point, working how-to for this "legacy" system exists.

Find it here

माकूचाकू said...

Cheating the portage

[quote]
I had the same problem - after digging a bit, I found that the courier-imap is built with the --without-authvchkpw configure flag. No clue why. I cheated and edited /usr/portage/net-mail/courier-imap/courier-imap-1.5.1.ebuild file to use --with-authvchkpw, and all was good.
Find it here[/quote]

Hope things start working now...
:-D